SouthernGospelBlog.com revamps mobile site

For several years, SouthernGospelBlog.com has had a mobile version, SouthernGospelBlog.mobi. Recent changes to the menu system here caused the .mobi menu to malfunction. So, today, we rolled out a revised mobile design; while I’ve tested it on my Droid, I don’t have phones on any other platforms to use for testing. Smartphone users, please let us know if there are any issues!


For more Southern Gospel news and commentary—follow our RSS feed or sign up for our email updates!

11 Letters to the Editor

Southern Gospel Journal welcomes letters to the editor. We will post the most thoughtful and insightful submissions. Ground rules: Don't attack or belittle groups or fellow posters, or advance heresies rejected by orthodox Christianity. Do keep comments positive, constructive, and on topic.
  1. Thank You for the fix. The update caused it to be quite painful. Looks great on the Verizon Thunderbolt which uses the Android operating system.

    • Great – glad to hear it’s working for you!

  2. At first glance, it looks great on the iPhone using Safari. Thanks for making it easy for us mobile users.

    • No problem, and I’m glad to hear it’s working for you. I really like the clean design on this one.

  3. It works with the I-Phone3! Had me worried for a few days.

  4. Just going to the latest technical post to pose this question… I don’t know if you can answer this or not. My Firefox live bookmark feed for the comments broke. Google Reader is up-to-date, but the Firefox hasn’t updated since you answered McCray yesterday morning. I had it to reload the feed several times and nothing changed. Just now I restarted Firefox and it said it was unable to load.

    I’m mostly asking out of curiosity; I assume I can fix it by deleting the bookmark and creating it again. I assume if you had made any changes, Google Reader would have disconnected (or whatever) as well.

    • I guess my question was, did this happen to anybody else?

    • I didn’t change anything – the comments feed is still at http://www.southerngospeljournal.com/comments/feed

      • It must just have been me. That’s the address I had in the feed, but when I deleted it and created it again, it worked.

      • Weird. Glad it’s working now!